One Response

Page 1 of 1
  1. Toddp
    Toddp April 6, 2018 at 3:56 pm | | Reply

    iPhone 4 and 4s are NOT supported dispite their claims.
    There is NO device manager and you can NOT install this on your iPhone without signing up for an Apple developer account

Leave a Reply